RFC 118 UNKNOWN DOCUMENTATION · SERVICES · STANDARDS

Recommendations for facility documentation

Recommendations for documenting services available to network users.

On rfc-editor.org ↗
PUBLISHED
April 1971
AUTHORS
R.W. Watson
STREAM
Legacy
COPIES REQUESTED FOR THE NIC
100 copies of each manual and update
DOI
10.17487/RFC0118

RFC text

Original text · RFC Editor View on rfc-editor.org ↗
Network Working Group                                     Richard Watson
Request for Comments: 118              Stanford Research Institute (ARC)
NIC: 5830                                                  16 April 1971

                RECOMMENDATIONS FOR FACILITY DOCUMENTATION


INFORMATION REQUIRED FOR EACH SERVICE AVAILABLE TO THE NETWORK

   There are two classes of information which a site needs to provide
   for each service or process it makes available over the Network:

      i) information required by system programmers in order to
      establish a connection to the facility

      ii) information required by a user to gain access to and use the
      facility

   The above two basic kinds of information which need to be in each
   facility description will comprise a "functional document" (see RFC
   115, NIC (5822,) for a description of functional documents and
   recommended procedures for updating them).

   The information required by user site system programmers may be a
   detailed document or a reference to a document containing a protocol
   common to several facilities or some combination of the above.  All
   information required such as connection socket numbers, message
   formats, and character set information must be included.  Two
   examples of system programmer type information are RFC 74, NIC
   (5417,) and RFC 105, NIC (5775,) prepared by James White of UCSB.


   The information required by user site users is of three types:

      a) information unique to Network users of the facility

      b) information in common between Network users and server site
      users of the facility

      c) information unique to particular Network user site.

   The information of type c) would be prepared by the user site from
   the information provided by the server site.  An example might be
   keying conventions required in order to send certain codes to the
   server site.

   Future documentation will probably be written with information types
   a) and b) above integrated in one document, but initially server
   sites will probably have user manuals or documentation for their
   local users and will need to write a short document giving any
   additional information required for Network users.  This information
   will vary, but might include a different login or control card
   sequence, varying echo or syntax for user sites operating with
   character at a time, line at a time, server site or user site echoing
   and so forth.  Some features available to server site users may not
   be available to Network user site users or certain features may
   behave differently.

   In addition to the above types of information, there should be
   instructions to the user on how to obtain help or answers to
   questions about using the facility.

   Information about how to obtain administrative access (charge
   numbers, etc.) to a site should be contained in the document, ARPA
   Network Current Guides to Network Facilities, NIC (5148,).  This
   information is being collected by BBN.  This document will in turn
   contain references to the functional documents containing detailed
   descriptions of available Network facilities and how to use them.

   Even if there are no special conventions or information unique to a
   Network user as opposed to a server site user, this fact should be
   explicitly stated in order to avoid confusion or uncertainty.

NETWORK INFORMATION CENTER POLICY ON DISTRIBUTION AND UPDATING OF
   DOCUMENTATION

   The Network Information Center will distribute and maintain one copy
   of each functional document describing a facility in each Network
   Station NIC Collection.  For this purpose we would appreciate it if
   100 copies of each manual and set of manual updates, when they occur,
   could be sent to the NIC.  Users at sites desiring their own copies
   of user documentation can obtain them either directly from the server
   site or by copying the master in their local NIC Collection.  In
   order that users may know where to obtain additional copies of the
   documentation, an address and a price, if any, should be included in
   the information about each facility.


        [ This RFC was put into machine readable form for entry ]
        [ into the online RFC archives by Mirsad Todorovac 10/98 ]

ISO Plain Language

On this page
PROBLEMProgrammers and users at other sites need information to connect to a network facility and use it.
MECHANISMThe RFC recommends a functional document with technical connection details, user instructions and any differences for network users.
DOCUMENTATION GUIDANCEThe Network Information Center is to distribute and maintain copies of each functional document in its station collections.

§1Two Kinds of Information

Each service made available over the network needs information for system programmers and for users. Programmers need details for establishing a connection, such as socket numbers, message formats and character-set information.

Users need information on how to access and use the service. These two kinds of information form a functional document, as described in RFC 115.

Programmers need connection details, while users need instructions for using the service. The RFC says both belong in a functional document.

§1Explain Network-Specific User Differences

User information can cover features unique to network users, features shared with users at the service site, and details unique to a particular user site. The user site prepares its own local information from details supplied by the service site.

At first, the service site may add a short network-user document to its existing manuals. It can explain differences in login or control-card sequences, echo behavior, syntax or available features. If network use has no special differences, the document should say so explicitly. It should also tell users how to get help.

Documentation should explain what changes for someone connecting over the network. If nothing changes, the document should say that clearly and tell users where to ask for help.

§2Distribution Through the NIC

The Network Information Center plans to distribute and maintain one copy of each facility's functional document in each Network Station NIC Collection. The RFC asks service sites to send 100 copies of each manual and its updates to the NIC.

Users may obtain documentation from the service site or copy it from their local NIC Collection. Each facility's information should include an address and any price for obtaining additional copies.

The NIC would keep a copy of each service document in station collections. Users could get a copy from the service site or their local collection.

§4References