RFC 800 INFORMATIONAL RFC SERIES · HISTORY · INDEX

RFC 700-799 index: Request For Comments summary notes: 700-799

A short, annotated list of a hundred RFCs, with a note on each one.

On rfc-editor.org ↗
PUBLISHED
November 1982
AUTHORS
J. Postel, J. Vernon
STREAM
Legacy
RFCS LISTED
100, from RFC 700 to RFC 799
PUBLICATION DATE
November 1982
DATE OF THE FIRST ENTRY, RFC 700
Aug 74
DATE OF THE LAST ENTRY, RFC 795
Sep 81
CORE PROTOCOL SPECIFICATIONS
IP, TCP, ICMP, UDP, FTP and Telnet
DOI
10.17487/RFC0800

RFC text

Original text · RFC Editor View on rfc-editor.org ↗
Network Working Group                                          J. Postel
Request for Comments: 800                                      J. Vernon
                                                                     ISI
                                                           November 1982



                     Requests For Comments Summary
                             Notes: 700-799



This RFC is a slightly annotated list of the 100 RFCs from RFC 700
through RFC 799.  This is a kind of status report on these RFCs.

RFC     Author       Date        Title
---     ------       ----        -----

799     Mills        Sep 81      Internet Name Domains

  A suggestion that, as the internet grows, the space of host names
  cannot remain a flat space of globally unique names, and that a
  hierarchy of name domains be introduced; see also RFC 822.

798     Katz         Sep 81      Decoding Facsimile Data From the
                                 Rapicom 450

  A description of the encoding/decoding procedure for Rapicom450
  facsimile machine.

797     Katz         Sep 81      Format for Bitmap Files

  The description of a simple file format for bitmap data.

796     Postel       Sep 81      Address Mappings

  A description of the way the addresses of a few actual networks are
  mapped into internet addresses.

795     Postel       Sep 81      Service Mappings

  A description of how the internet type of service is mapped into the
  actual service parameters of a few particular networks, and vice
  versa.

794     Cerf         Sep 81      Pre-Emption

  Discusses how pre-emption of TCP connection can be implemented.
  Replaces IEN 125.

793     Postel       Sep 81      Transmission Control Protocol

  The specification of TCP.  Replaces RFCs 761 and 675.

792     Postel       Sep 81      Internet Control Message Protocol

  The specification of ICMP.  Replaces RFCs 777 and 760.

791     Postel       Sep 81      Internet Protocol

  The specification of IP.  Replaces RFC 760.

790     Postel       Sep 81      Assigned Numbers

  The list of numbers assigned for networks, protocols, etc.  Replaces
  RFCs 776, 770, 762, 758, 755, 750, 739, 604.

789     Rosen        Jul 81      Vulnerabilities of Network Control
                                 Protocols:  An Example

  A description of an outage in ARPANET service and the process of
  determining the cause; also, subtleties of designing network
  protocols.

788     Postel       Nov 81      Simple Mail Transfer Protocol

  An old version; see RFC 821.

787     Chapin      July 81      Connectionless Data Transmission
                                 Survey/Tutorial

  A discussion of datagram service.  Intended for submission to
  international standards bodies.

786     Sluizer     July 81      Mail Transfer Protocol:  ISI TOPS20
                                 MTP-NIMAIL Interface

  The description of the way mail is passed between the MTP and the
  NIMAIL programs in ISI TOPS20.  Outdated.

785     Sluizer     July 81      Mail Transfer Protocol:  ISI TOPS20
                                 File Definitions

  The description of the file format for passing mail to the MTP program
  from user mail programs in ISI TOPS20.  Outdated.

784     Sluizer     July 81      Mail Transfer Protocol:  ISI TOPS20
                                 Implementation

  The description of the program structure for the MTP implementation in
  the ISI TOPS20.  Outdated.

783     Sollins     June 81      The TFTP Protocol Revision 2

  The specification of TFTP.  Replaces RFCs 768, 764 and IEN 133.

782     Nabielsky   undated      A Virtual Terminal Management Model

  A description of the elements of a virtual terminal and the management
  of communications between them.

781     Su           May 81      A Specification of the Internet
                                 Protocol IP Timestamp Option

  The description of IP Timestamp option, now included in the IP
  specification (RFC 791).

780     Sluizer      May 81      Mail Transfer Protocol

  An outdated Mail protocol; see RFC 821.

779     Killian      Apr 81      TELNET SEND-LOCATION Option

  Definition of this Telnet option.

778     Mills     18 Apr 81      DCNet Internet Clock Service

  Specifies a format and procedure for the exchange of messages to
  maintain synchronized  clocks.

777     Postel       Apr 81      Internet Control Message Protocol

  An old version; see RFC 792.

776     Postel       Jan 81      Assigned Numbers

  An old version; see RFC 790.

775     Mankins      Dec 80      Directory Oriented FTP Commands

  The definition of additional FTP Commands related to directory
  management.

774     Postel       Oct 80      Internet Protocol Handbook Table of
                                 Contents

  An out-of-date table of contents for an Internet Protocol Handbook.

773     Cerf         Oct 80      Comments on NCP/TCP Mail Service
                                 Transition Strategy

  A discussion of issues in the transition from NCP to TCP, particularly
  as related to MAIL Service.

772     Sluizer      Sep 80      Mail Transfer Protocol

  An old version of a Mail Protocol; see RFC 821.

771     Cerf         Sep 80      Mail Transition Plan

  A plan for supporting mail service in the transition from NCP to TCP;
  see also RFC 801.

770     Postel       Sep 80      Assigned Numbers

  An old version; see RFC 790.

769     Postel    26 Sep 80      Rapicom 450 Facsimile File Format

  The definition of the exchange format of the encoded facsimile data of
  the Rapicom 450; see also RFC 798.

768     Postel    28 Aug 80      User Datagram Protocol

  The specification of the UDP.

767     Postel       Aug 80      A Structured Format for  Transmission
                                 of Multi-Media Documents

  The definition of the format for the document of a multimedia message.

766     Postel       Jul 80      Internet Protocol Handbook

  An out-of-date table of contents for the Internet Protocol Handbook.

765     Postel       Jun 80      File Transfer Protocol

  The specification of FTP.

764     Postel       Jun 80      Telnet Protocol Specification

  The specification of Telnet.

763     Abrams     7 May 80      Role Mailboxes

  A call for mailboxes with role names, such as "Management".

762     Postel       Jan 80      Assigned Numbers

  An old version; see RFC 790.

761     Postel       Jan 80      DOD Standard Transmission Protocol

  An old version; see RFC 793.

760     Postel       Jan 80      DOD Standard Internet Protocol

  An old version; see RFC 791.

759     Postel       Aug 80      Internet Message Protocol

  The definition of the protocol and format for the exchange of
  multimedia mail.  Replaces RFC 753.

758     Postel       Aug 79      Assigned Numbers

  An old version; see RFC 790.

757     Deutsch   10 Sep 79      A Suggested Solution to the Naming,
                                 Addressing, and Delivery Problem for
                                 ARPANET Message Systems

  Discusses several proposals for handing the name to address to route
  processing for computer mail.  Favors a solution based on unique-ids
  and a data base, see also RFCs 759, 821 and 822.

756     Pickens      Jul 79      The NIC Name server--A  Datagram-Based
                                 Information Utility

  Describes a Host Name to Address look up service.

755     Postel     3 May 79      Assigned Numbers

  An old version; see RFC 790.

754     Postel     6 Apr 79      Out-of-Net Host Addresses for Mail

  A discussion of options for addressing computer mail beyond the
  ARPANET.

753     Postel       Mar 79      Internet Message Protocol

  An old version; see RFC 759.

752     Crispin    3 Jan 79      A Universal Host Table

  Describes the host table used at MIT and Stanford.  This has several
  extensions and generalizations from the NIC standard and the table
  used by most Tenex and TOPS20 hosts.

751     Lebling   10 Dec 78      Survey of FTP Mail and MLFL

  A survey of hosts' responses to probes of their FTP servers to see if
  servers (a) accept mail for unknown users and (b) support the MAIL and
  MLFL commands.

750     Postel    26 Sep 78      Assigned Numbers

  An old version; see RFC 790.

749     Greenberg 18 Sep 78      Telnet SUPDUP-OUTPUT Option

  Updates RFC 736; see also RFCs734, 746 and 747.

748     Crispin    1 Apr 78      TELNET RANDOMLY-LOSE Option

  Defines this Telnet option (note the date of this memo).

747     Crispin   21 Mar 78      Recent Extensions to the SUPDUP
                                 Protocol

  An update to the SUPDUP protocol (RFC 734); see also RFCs 749, 746 and
  736.

746     Stallman  17 Mar 78      The SUPDUP Graphics Extension

  An extension of SUPDUP for Graphics; see also RFCs 734, 736, 747 and
  749.

745     Beeler    30 Mar 78      JANUS Interface Specifications

  The specification of a symmetrical 1822 style interface.

744     Sattley    8 Jan 78      MARS - A Message Archiving and
                                 Retrieval Service

  The description of a database service for computer mail messages,
  which operates via computer mail.

743   Harrenstien 30 Dec 77      FTP extension:  XRSQ/XRCP

  An extension to FTP mail to allow more efficient transmission of
  computer mail.  Now incorporated into SMTP; see RFC788.

742   Harrenstien 30 Dec 77      NAME/FINGER Protocol

  Defines the Name or Finger Protocol which allows one to get "who is
  on" or "where is user x" information from another host.

741     Cohen     22 Nov 77      Specifications for the Network Voice
                                 Protocol NVP

  Defines the protocol used in the ARPANET packet speech experiments.

740     Braden    22 Nov 77      NETRJS Protocol

  Defines the protocol used for Remote Job Entry on the UCLA CCN IBM
  system; replaces RFCs 599 and 189.

739     Postel    11 Nov 77      Assigned Numbers

  An old version; see RFC 790.

738   Harrenstien 31 Oct 77      Time Server

  Defines the Time Server Protocol; see IEN 142 for the TCP and VDP
  versions.

737   Harrenstien 31 Oct 77      FTP Extension: XSEN

  An extenion to the Mail procedures.  This function is incorporated in
  the SMTP; see also RFC 821.

736     Crispin   31 Oct 77      TELNET SUPDUP Option

  Defines the procedure for negotiating to use the SUPDUP, protocol as a
  TELNET option; see also RFCs 734, 746, 747 and 749.

735     Crocker    3 Nov 77      Revised TELNET Byte Macro Option
                                 Obsoletes 40306

  Defines a Telnet option for assigning codes to stand for strings in
  Telnet connections.  Replaces RFC 729.

734     Crispin    7 Oct 77      SUPDUP Protocol

  Description of a terminal control protocol used at STANFORD and MIT;
  see also RFCs 736, 746-749.

733     Crocker   21 Nov 77      Standard for the Format of ARPA Network
                                 Text Messages

  Specification of the format for the headers of computer mail.  An old
  version; see RFC 822.

732     Day       12 Sep 77      TELNET Data Entry Terminal Option

  The specification of a Telnet Option for the control of a data entry
  display terminal.  Replaces RFC 731.

731     Day       27 Jun 77      TELNET Data Entry Terminal Option

  An old version; see RFC 732.

730     Postel    20 May 77      Extensible Field Addresing

  Discusses some ideas on addressing that come up in the context of
  changing from 8-bit to 24-bit network addresses.

729     Crocker   13 May 77      TELNET Byte Macro Option

  An old version; see RFC 735.

728     Day       27 Apr 77      A Minor Pitfall in the Telnet Protocol

  Warns of the possibility of an unexpected occurence in Telnet
  resulting from the interaction between option subnegotiations and the
  telnet SYNCH operation.

727     Crispin   27 Apr 77      TELNET Logout Option

  Defines a telnet option for causing a logout.

726     Postel     8 Mar 77      Remote Controlled Transmission and
                                 Echoing Telnet Option

  Defines a Telnet option for controlling the transmission and echoing
  of data to smooth the response to use in high transmission delay
  environments; see also RFCs 719 and 718.

725     Day        1 Mar 77      An RJE Protocol for a Resource Sharing
                                 Network

  Describes a possible Remote Job Entry protocol.

724     Crocker   12 May 77      Proposed Official Standard for the
                                 Format of ARPA Network Messages

  An old version; see RFC 822.

722     Haverty   16 Sep 76      Thoughts on Interactions in Distributed
                                 Services

  A discussion on the design of interactive distributed services and the
  kinds of primitive operations that are needed.

721     Garlick    1 Sep 76      Out of Band Control Signals in a Host
                                 to Host Protocol

  A discussion of the control signals in transport protocols (e.g.,
  NCP's Interrupt or TCP's Urgent).

720     Crocker    5 Aug 76      Address Specification Syntax for
                                 Network Mail

  A discussion of computer mail addresses, with comments on real names
  vs. mailboxes, and mailing lists; see also RFC 819.

719     Postel    22 Jul 76      Discussion on RCTE

  A short discussion of RCTE implementation issues; see also RFCs 726
  and 718.

718     Postel    30 Jun 76      Comments on RCTE from the TENEX
                                 Implementation Experience

  A short note on the Tenex implementation of RCTE; see also RFCs 726
  and 719.

717     Postel     1 Jul 76      Assigned Network Numbers

  An old version; see RFC 790.

716     Levin     24 May 76      Interim Revision to Appendix F of BBN
                                 1822

  A short note updating the specification of the very Distant Host 1822
  interface.

714     McKenzie  21 Apr 76      A Host/Host Protocol for an
                                 ARPANET-type Network

  A specification of a NCP-like protocol for an ARPA-like network.
  Interesting to compare to the NCP specification to see what the author
  would do differently.

713     Haverty    6 Apr 76      MSDTP -- Message Services Data
                                 Transmission Protocol

  The specification of a set of Data Primitives for building interactive
  services.

712     Donnelley  5 Feb 76      A Distributed Capability Computing
                                 System DCCS

  A description of a Distributed Capability based computing system.

708     White      5 Jan 76      Elements of a Distributed  Programming
                                 System

  A description of a Distributed programming system; see also RFC 707.

707     White     23 Dec 75      A High-Level Framework for
                                 Network-Based Resource Sharing

  A description of a programming environment for network-based programs;
  see also RFC 708.

706     Postel     8 Nov 75      On the Junk Mail Problem

  A short note pointing out that the ARPANET maybe subject to a "denial
  of service" attack by a misbehaving host.

705     Bryan      5 Nov 75      Front-End Protocol

  Describes a protocol used between a PDP-11 (the ARPANET front end) and
  a B6700 to support network communication.

704     Santos    15 Sep 75      IMP/Host and Host/IMP Protocol Change

  Describes the changes to the 1822 interface to eliminate the
  restriction of 63 IMPs.

703     Dodds     11 Jul 75      Survey of New-Protocol Telnet Servers

  A poll of Telnet servers to check implementation status and Telnet
  options.  Updates RFCs 702, 701, 679 and 669.

702     Dodds     25 Sep 74      Survey of New-Protocol Telnet Servers

  An earlier poll of Telnet server implementation status; see also
  RFC's703, 701, 679, and 669.

701     Dodds        Aug 74      Survey of New-Protocol Telnet Servers

  An earlier poll of Telnet server implementation status; see also RFCs
  703, 702, 679 and 669.

700     Mader        Aug 74       A Protocol Experiment

  Describes a protocol based loosely on a very early version of TCP,
  used to send data to a printer server.

ISO Plain Language

On this page
PROBLEMThe RFC series grows one document at a time, and early documents were often replaced by later ones without the reader being told. By 1982 the list of the first few hundred RFCs was hard to navigate.
MECHANISMRFC 800 is a status report on the hundred RFCs numbered 700 to 799. Each entry gives the number, the author, the date, the title and a sentence or two saying what the document was and, where it applies, what later document replaced it.
WHAT IT COVERSThe list covers the founding specifications of the Internet's core protocols, the early mail and file transfer work, the first attempts at a hierarchical name system, and a long run of Assigned Numbers updates. It is an Informational document and has not been obsoleted.

§1A Status Report on a Hundred RFCs

RFC 800 is a slightly annotated list of the 100 RFCs from RFC 700 through RFC 799. The RFC calls itself a kind of status report on these RFCs, and it was written by Jon Postel and Joyce Vernon at ISI in November 1982.

The purpose it serves is simple. By 1982 the series already had a long tail of documents that had been quietly replaced by newer ones. An Assigned Numbers memorandum, for instance, appeared in many versions, and the early versions of the core protocol specifications had all been superseded. A reader who picked up an old RFC had no way of telling whether it was still the current statement of the protocol or not, so the list answers that question in a line for each entry.

The material covered by these hundred documents is broad. It includes the founding specifications of the Internet itself and of the protocols that ran over it, the first work on electronic mail, the beginnings of a name system, a long series of Telnet options, and a great deal of housekeeping about assigned numbers. The list also captures a period when the protocols were still being designed rather than merely documented, with several entries describing proposals and surveys rather than final specifications.

The list was written so that a reader holding an old document could tell at a glance whether it still mattered. For most entries the answer is a pointer to the document that replaced it.

§2The Shape of Each Entry

Every entry has the same four-part header line: the RFC number, the author's name, the date, and the title. Beneath that is a short annotation, usually one or two sentences, saying what the document contains.

The header lines are set out in columns, with the RFC number first, then the author, then the date, and then the title, which wraps where it is long. The dates are given in the compact form of the period, with a two-digit year, so RFC 793 is dated Sep 81 and RFC 700 is dated Aug 74.

The annotations are written as descriptions rather than as reviews. For example, the entry for RFC 797, Format for Bitmap Files, reads that it is the description of a simple file format for bitmap data. The entry for RFC 787, Connectionless Data Transmission Survey/Tutorial, notes that it is a discussion of the datagram service intended for submission to international standards bodies. Where a document has a particular standing, the annotation says so: RFC 778, DCNet Internet Clock Service, specifies a format and procedure for exchanging messages to keep clocks synchronised, and RFC 785 through RFC 784 are each marked as describing the ISI TOPS20 mail transfer program and are marked outdated.

Every entry looks the same: number, author, date, title, and a sentence about what is inside. The wording is plain, and it is meant to be read quickly rather than studied.

§3What the Hundred RFCs Were About

The most important documents in the list are the specifications of the protocols the Internet is built on, and the entries make that clear. RFC 791 is the Internet Protocol, replacing RFC 760. RFC 793 is the Transmission Control Protocol, replacing RFCs 761 and 675. RFC 792 is the Internet Control Message Protocol, replacing RFCs 777 and 760. RFC 768 is the User Datagram Protocol. RFC 765 is the File Transfer Protocol and RFC 764 is the Telnet Protocol Specification.

Mail occupies a large part of the list, and it shows the protocol settling down. RFC 733 and RFC 724 are earlier versions of the format for computer mail headers, and both are annotated as old versions of RFC 822. RFC 772, RFC 780 and RFC 788 are earlier mail transfer protocols, all pointed at RFC 821. Several documents in the 780s describe the ISI TOPS20 mail transfer implementation in detail and are marked outdated.

Names and addresses get their own thread. RFC 799 suggests that as the Internet grows, host names cannot remain a flat space of globally unique names and that a hierarchy of name domains should be introduced. RFC 756 describes a host name to address lookup service, RFC 752 describes the host table used at MIT and Stanford, and RFC 799 and RFC 757 both discuss ways of getting from a name to an address.

Two entries are worth singling out because they read as warnings rather than specifications. RFC 789 describes an outage in ARPANET service and the process of determining the cause, along with subtleties in designing network protocols. RFC 706 points out that the ARPANET might be subject to a denial of service attack by a misbehaving host, and RFC 728 warns of an unexpected occurrence in Telnet resulting from the interaction between option subnegotiations and the SYNCH operation.

The list covers the protocols everyone uses, the mail and file transfer systems of the time, the first attempts to give the Internet a hierarchy of names, and a few notes from the operating incidents that shaped later design.

The core protocol specifications listed in RFC 800
  • RFC 791Internet Protocol — The specification of IP. Replaces RFC 760.
  • RFC 793Transmission Control Protocol — The specification of TCP. Replaces RFCs 761 and 675.
  • RFC 792Internet Control Message Protocol — The specification of ICMP. Replaces RFCs 777 and 760.
  • RFC 768User Datagram Protocol — The specification of UDP.
  • RFC 765File Transfer Protocol — The specification of FTP.
  • RFC 764Telnet Protocol Specification — The specification of Telnet.
Some of the entries, by the date given in the list
  1. 1974RFC 700, A Protocol Experiment
  2. 1976RFC 721, Out of Band Control Signals in a Host to Host Protocol
  3. 1977RFC 734, SUPDUP Protocol
  4. 1978RFC 745, JANUS Interface Specifications
  5. 1980RFC 759, Internet Message Protocol
  6. 1981RFC 793, Transmission Control Protocol

§4How the List Tracks Supersession

The annotations carry the status information, and they use a small set of repeated phrases.

An entry that has been replaced by a later document reads as an old version and points to the newer number. RFC 776 is an old version and the entry says to see RFC 790. RFC 777 is an old version and the entry says to see RFC 792. RFC 761 is an old version and the entry says to see RFC 793. This phrase is used for a long run of the Assigned Numbers memoranda, from RFC 758 and RFC 755 through RFC 750 and RFC 739, and also for the early versions of the mail and message formats.

The newer document points back. RFC 790, the Assigned Numbers memorandum, says that it replaces RFCs 776, 770, 762, 758, 755, 750, 739 and 604. RFC 791 replaces RFC 760, RFC 792 replaces RFCs 777 and 760, and RFC 793 replaces RFCs 761 and 675.

Three other phrasings appear. A document that has been absorbed into a later protocol is described as now incorporated into it: the FTP mail extension in RFC 743 is now incorporated into SMTP, and the FTP extension XSEN in RFC 737 is incorporated in SMTP. A document that is simply gone is marked outdated, as with the ISI TOPS20 mail transfer documents. And a see also phrase points at a related document without saying which one replaced which, as with RFC 757, which points at RFCs 759, 821 and 822, and RFC 799, which points at RFC 822.

The status is in the wording. An old document says so and names the replacement; the replacement names the documents it took over from. A few entries are marked outdated or point sideways to something related.

The phrases the list uses to record status
  • An old version; see RFC NUsed on the earlier Assigned Numbers and protocol documents that a later one replaced.
  • Replaces RFCs ...Used on the newer document, naming the ones it took over from.
  • OutdatedUsed for the ISI TOPS20 mail transfer documents, which described an implementation long gone.
  • Now incorporated into ...Used where a later protocol absorbed the function of an earlier one.
  • See also RFC ...Used to point at related documents without saying which replaced which.

§5What the List Still Shows

Read as a whole, the list is a snapshot of the Internet at a particular moment. The dates run from Aug 74, when RFC 700 describes a protocol experiment loosely based on a very early version of TCP and used to send data to a printer server, through to Sep 81, when RFC 793 and RFC 792 were written. The intervening years show the protocol suite being written down, replaced and written down again.

Several entries are about the design process rather than a finished protocol. RFC 714 specifies a host-to-host protocol for an ARPANET-like network and is noted as interesting to compare with the NCP specification to see what the author would do differently. RFC 722 discusses the design of interactive distributed services and the kinds of primitive operations needed. RFC 703, 702 and 701 are successive surveys of new-protocol Telnet servers, each checking implementation status and Telnet options, and each pointing at the ones before it.

The housekeeping entries fill much of the list. Assigned Numbers was reissued many times, each version naming the ones it replaced, and the list is the clearest single view of how often that happened. The remaining entries cover terminal options and protocols for specific host systems, facsimile formats, a database service for computer mail messages, and a set of remote job entry protocols.

Taken together the entries are a record of the Internet being designed rather than just written down, with the housekeeping of assigned numbers running through the whole thing.

§6References